首页
学习
活动
专区
工具
TVP
发布
社区首页 >问答首页 >我在安装npm中的nrm,为什么会安装失败?

我在安装npm中的nrm,为什么会安装失败?

提问于 2022-04-18 18:32:45
回答 2关注 0查看 2.3K

PS C:\Users\zyy> npm install nodemon -g

changed 116 packages, and audited 117 packages in 17s

16 packages are looking for funding

run `npm fund` for details

found 0 vulnerabilities

PS C:\Users\zyy> npm install nrm -g

npm WARN deprecated uuid@3.4.0: Please upgrade to version 7 or higher. Older versions may use Math.random() in certain circumstances, which is known to be problematic. See https://v8.dev/blog/math-random for details.

npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142

npm WARN deprecated har-validator@5.1.5: this library is no longer supported

removed 222 packages, changed 60 packages, and audited 94 packages in 19s

4 packages are looking for funding

run `npm fund` for details

2 vulnerabilities (1 moderate, 1 high)

To address issues that do not require attention, run:

npm audit fix

To address all issues (including breaking changes), run:

npm audit fix --force

Run `npm audit` for details.

PS C:\Users\zyy> npm audit fix

npm WARN audit request to https://registry.npmjs.org/-/npm/v1/security/audits/quick failed, reason: Client network socket disconnected before secure TLS connection was established

undefined

npm ERR! audit endpoint returned an erro

PS C:\Users\zyy> npm audit fix --force

npm WARN using --force Recommended protections disabled.

npm WARN audit request to https://registry.npmjs.org/-/npm/v1/security/audits/quick failed, reason: Client network socket disconnected before secure TLS connection was established

undefined

npm ERR! audit endpoint returned an erro

PS C:\Users\zyy>

回答

和开发者交流更多问题细节吧,去?写回答
相关文章

相似问题

相关问答用户
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档
http://www.vxiaotou.com